易语言-过滤文本剩数字

俊飞

2022-09-06 13:27

.版本 2


.子程序 过滤文本只剩数字, 文本型

.参数 消息内容, 文本型

.局部变量 TXT0, 文本型

.局部变量 TXT1, 文本型

.局部变量 TXT2, 文本型

.局部变量 LL1, 整数型

.局部变量 LL2, 整数型


.如果真 (消息内容 ≠ “”)

    TXT1 = 删全部空 (消息内容)

    LL1 = 取文本长度 (TXT1)

    TXT2 = “”

    .计次循环首 (LL1, LL2)

        TXT0 = 取文本中间 (TXT1, LL2, 1)

        .如果真 (取代码 (TXT0, ) ≥ 48 且 取代码 (TXT0, ) ≤ 57)

            TXT2 = TXT2 + TXT0

        .如果真结束


    .计次循环尾 ()


.如果真结束

返回 (TXT2)


0 条评论

评论:

发送